
Important - Before You Go Over the Guide 
Wishlist Member WooCommerce Plus was developed to integrate Wishlist Member and WooCommerce to allow you to sell 
membership products. 

 
Wishlist Member WooCommerce Plus can be used for 2 scenarios: 

1. Local Membership Products - WooCommerce & Wishlist Member are installed on the EXACT same domain and WordPress 
installation 
 

2. External Membership Products - WooCommerce & Wishlist Member are installed on SEPARATE domains (different 
WordPress installations) 

 
 
To get to the part of the guide relevant for you, please answer the below question: 

Are Your WooCommerce Store and Wishlist Member membership site installed on the exact same domain and WordPress installation 
OR are they installed on different domains?  

 
WooCommerce & Wishlist Member on the Same Domain >> Go to this guide 

WooCommerce & Wishlist Member on Separate Domains >> Start Here 

 

http://happyplugins.com/wp-content/uploads/wishlist-member-woocommerce-plus-manual.pdf


 
 

 

 

External Membership Sites 
Add-Ons Bundle 

 Manual 
WooCommerce & Wishlist Member on Separate Domains 

 

 

http://happyplugins.com/?utm_source=pdf-manual&utm_medium=wlm-woocommerce-plus&utm_campaign=HappyPlugins
http://happyplugins.com/?utm_source=pdf-manual&utm_medium=wlm-woocommerce-plus&utm_campaign=HappyPlugins


 
 

Table of Contents 
Introduction to the External Membership Sites Add-Ons Bundle 

Complete Activation Process Summary in 4 Steps 

Step #1: Downloading the Add-Ons   

Step #2: Installing and Activating the Add-Ons 

Step #3: Activating the Add-Ons Licenses 

Step #4: Setting Up a New External Membership Product 

FAQ 

About HappyPlugins  

Contact Information  

Got Any Suggestions? 
 

  

http://happyplugins.com/?utm_source=pdf-manual&utm_medium=wlm-woocommerce-plus&utm_campaign=HappyPlugins


 
 

Introduction to External Membership Sites Add-Ons Bundle 
 

 

If your WooCommerce store and Wishlist Member membership site are installed on separate websites you will need to also get the 
External Membership Sites Add-Ons Bundle. 

Examples of Different Websites 
 
Different domains: 

• Your WooCommerce store is located in - http://yourstore.com  
• Your Wishlist membership site is located in - http:// yourmembership.com 

Different sub-domains: 

• Your WooCommerce store is located in - http://store.yourdomain.com  
• Your Wishlist membership site is located in - http://membership.yourdomain.com 

Different directories: 

• Your WooCommerce store is located in - http://yourdomain.com/store 
• Your Wishlist membership site is located in - http://yourdomain.com/membership 

 

The External Membership Sites Add-Ons Bundle includes 2 add-ons: 

• The External Membership Sites Add-On 
• The Remote Access Add-On 

 

* Relevant only if your WooCommerce store and Wishlist Member are located in 2 different WordPress installations 
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The External Membership Sites Add-On 
 
The External Membership Sites Add-on is installed on the same website where your WooCommerce store is and it allows you to 
manage all external membership products in one table. 

The External Membership Products table will be displayed only after you install and activate the add-on. 

The information displayed in the table includes:  

• Product Name – The product's name 
• Status – The product's status, for example: published / draft / pending 
• Website's URL – The URL of the membership site users will register to when purchasing the product 
• Level ID – The membership level's ID 
• Authenticate – Notifies you if the integration between your store and the membership site is successful for each product 

(will be explained further in the manual when we explain about the Remote Access add-on) 
• Actions – You can click to edit the product's details 
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The Remote Access Add-on 
 
The Remote Access Add-On is installed on your membership site and not on your WooCommerce website. The Remote Access add-
on connects your online store and your membership site, and make sure that members will be registered to the relevant membership 
site correctly (both new and existing members). 

You must have the Remote Access Add-On installed on every external membership site you want to register members to. 

After you activate the Remote Access add-on, you will be able to see all the information you need in order to set the integration 
between your membership site and your WooCommerce store. 

You will see 2 types of information: 

1. General Wishlist Member information  
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2. Encoded membership levels setting to easily copy-paste the details required for the external integration (we go over how and 
where to insert the code further down the manual) 
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How Many Licenses Will I Need for Each Add-On? 
 

For every WooCommerce store you will need 1 license of: 

• Wishlist Member WooCommerce Plus Plugin 
• External Membership Sites Add-On 

For every External membership site you will need 1 license of: 

• Remote Access Add-On 

 
For example: 

If you want to sell all your products from one WooCommerce store, and you want to integrate your store's products to 3 
membership sites you will need: 

• Wishlist Member WooCommerce Plus Plugin – 1 License 
• External Membership Sites Add-On – 1 License  
• Remote Access Add-On – 3 Licenses (one license is issued to you for free when you purchase the External Membership Sites 

Add-On) 
 

If you want to sell all your products from 2 different WooCommerce stores, and you want to integrate all products from 2 stores to 
one membership site you will need: 

• Wishlist Member WooCommerce Plus Plugin – 2 Licenses 
• External Membership Sites Add-On – 2 Licenses  
• Remote Access Add-On – 1 License (one license is issued to you for free when you purchase the External Membership Sites 

Add-On) 
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Complete Activation Process Summary in 4 Steps 
Follow the steps below to have the External Membership Sites & Remote Access Add-Ons fully activated and functioned on your 
membership site. 

Detailed information about each step will be given further down this manual: 

Step #1: Downloading the Add-Ons 

The External Membership Sites add-on does not have a zip file, only a license key. Download the Remote Access Add-Ons zip file 
from the Purchase Receipt you received to your email. 

Step #2: Installing & Activating the Add-Ons 

Install the Remote Access add-on zip file on your Wishlist Member membership site just like any other WordPress plugin from the 
Plugins menu > Add New. 

Step #3: Activating the Add-Ons Licenses 

Activate the add-ons' license using the license key you received to your email.  

The External Membership Sites add-on license key needs to be added in the License Key field on your WooCommerce website inside 
Wishlist Member Easy Digital Downloads Plus > Add-Ons 

The Remote Access add-ons license key needs to be added in the License Key field on your Wishlist Member membership site  

Step #4: Setting Up ad New External Membership Product 

In order to integrate WooCommerce and Wishlist Member and start selling external membership products you need to follow the 4 
simple steps as described in Step 4. 
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Step #1: Downloading the Add-Ons  
The External Membership Sites Add-On does not have a zip file, just 
copy its license key and paste it inside Wishlist Member WooCommerce 
Plus plugin > Add-Ons tab (we go over this in details on step #3) 

The Remote Access Add-On does have a zip file and it can be 
downloaded from the Purchase Receipt received to your email as seen in 
the screenshot to your right: 

  

Click to 
download the 
Remote Access 
Add-On zip file 

The license keys 

http://happyplugins.com/?utm_source=pdf-manual&utm_medium=wlm-woocommerce-plus&utm_campaign=HappyPlugins


 
 

Step #2: Installing & Activating the Add-Ons 
As written in Step #1, the External Membership Sites does not include a zip file, we go over how to activate its license in Step #3. 

The Remote Access Add-On can be installed easily, just like any other WordPress plugin.  

 
You can install the add-on 2 ways: 

1. Upload the folder found inside the zip file to your plugins’ folder in your WordPress installation 

2. Go to the plugins menu, click the "Add New" and choose the zip file you have downloaded 

 

Where to Install the Remote Access Add-On? 
 

The Remote Access Add-On needs to be installed on your Wishlist Member membership site 

* Every installation of Remote Access Add-On requires a separate license (one license in included in the bundle) 
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Step #3: Activating the Add-Ons Licenses 
After you have installed and activated the External Membership Sites & Remote Access Add-Ons you need to activate their licenses. 

Activating the External Membership Sites Add-On License: 
 
First you need to make sure you have installed and activated Wishlist Member WooCommerce Plus plugin (as explained in the 
beginning of this guide). 

On your WooCommerce website go to the WordPress menu > WL Extensions > Wishlist Member WooCommerce Plus > AddOns Tab 
> Insert the license key from the purchase receipt to the right field under "License Key" as seen in the screenshot below.
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Right after you activate the External Membership Sites Add-On you will see the External Membership Products section added to the 
Membership Products Tab: 

 

  

Products will 
be added 
automatically 
after you 
complete the 
integration 
(in Step #4) 
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Activating the Remote Access Add-On License: 
 
On your membership site go to the WordPress menu > WL Extensions > Wishlist Member WooCommerce Plus Remote Access > 
Insert the license key from the purchase receipt to the right field under "License Key" as seen in the screenshot below: 
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Step #4: Setting Up a New External Membership Product 
In order to integrate WooCommerce and Wishlist Member and start selling external membership products you need to follow the 4 
simple steps below in both your WooCommerce store and your membership site. 

 
Follow these Steps: 
 
1. Login to your Wishlist Member 
membership site and go to WL Extensions 
> Wishlist Member WooCommerce Plus 
Remote Access > Membership Levels 
Products tab (in the WordPress menu) 

2. Scroll down to the "Levels Products 
Settings" option and copy the code of your 
chosen membership level 
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3. Now login to your WooCommerce 
store and go to the WordPress menu > 
Products > Add Product 

4. Scroll down to WooCommerce 
Product Data > Wishlist External 
Membership tab (as seen in the 
screenshot), paste the code in the 
"Import Settings" field and click the 
Publish button 
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That's it! Wishlist Member API, URL 
and Level ID have been added 
automatically.  

Your product is now integrated with 
your membership site, so whenever 
someone buys the product, he will 
be automatically added to the 
correct membership level in the 
correct membership site (handles 
both new and existing members) 
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FAQS 
What version of WooCommerce plugin I need in order the plugin? 
You will need to use WooCommerce version 2.3 

Can I use only the bundle, without the plugin Wishlist Member WooCommerce Plus? 
No, the External Membership Sites & Remote Access Add-Ons are an addition to the main plugin, you must also purchase Wishlist 
Member WooCommerce Plus for the add-ons to work. 

If my WooCommerce Store and Wishlist Member are installed on the exact same domain, will I 
need to purchase the "External Membership Sites Add-Ons Bundle"? 
If both WooCommerce and Wishlist Member are installed on the exact WordPress installation, you will not need the "External 
Membership Sites Add-Ons Bundle", only the main plugin - Wishlist Member WooCommerce Plus 

If my WooCommerce store and Wishlist membership site are located in different sub-domains or 
files, will I still need to purchase the "External Membership Sites Add-Ons Bundle"? 
Yes, because you have 2 different WordPress installations in 2 different sub-domains, you will need to use the add-on. 

Can I Purchase More Licenses of the Remote Access Add-On Separately? 
Yes, if you need to integrate multiple membership sites and you need more licenses (each membership site requires a license), you 
can purchase them separately in this link >> Purchase Remote Access Add-On 

It sounds complicated to operate the plugin and add-ons to work with an external membership 
site, where can I find more information on how to integrate it exactly? 
Actually, it is very simple and easy to install and activate all 3 and make them work seamlessly. The process is very quick and 
requires only 4 simple steps. You can find all the information in this manual. 
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Does the plugin have any conflicts with other plugins? 
As far as we know, the plugin does not conflict with any other plugin. Wishlist Member WooCommerce Plus keeps a very strict code 
method so the chances that it’s causing any problem are very low. If you have any problems or conflicts, please contact the support 
department. 

Does the plugin integrate with every membership site platform? 
No, Wishlist Member WooCommerce Plus is a Wishlist Member dedicated plugin. 

I have more questions and I haven't found my answers, how can I contact you? 
If you haven't found your answers in the product's page and in the guide, please contact our support team and we will get back to 
you shortly  
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About HappyPlugins  
HappyPlugins was established in 2010 to develop plugins and extensions for the WordPress platform.  

The majority of the plugins are developed as white label according to our clients’ specific requirements. 

In late 2010 we opened a new branch under HappyPlugins for developing Wishlist Member dedicated plugins called Wishlist Member 
Developers.  

Our team here at Wishlist Member Developers develops commercial and custom plugins for the Wishlist Member platform. 

Expertise 

Our expertise includes: 

 In depth knowledge and understating in the web industry 
 UXI design and improvement 
 Experience in traffic and media buying for large companies 
 Subscription-based marketing and retention 
 Conversions and flow design optimization 
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Contact information  
The Store 
Find unique WordPress 
plugins on our plugins’ store. 
We have designed and 
developed hundreds of 
custom plugins and solutions 
for customers so far and are 
selling the best of them in our 
store. 
 

The Service 
Looking for a special solution 
for WordPress, one that will 
complete the missing puzzle 
piece in your website? Please 
send us your request and we 
promise to return to you no 
later than 72 hours. 

The Blog 
Interested in our development 
work or want to improve your 
WordPress development 
skills? Check our blog; there 
we publish unique prescriptive 
and sample codes from our 
own plugins. 
 

 

Contact Support 

 Our support team is always available to help you with any question you may have.  

All of our products include 3 months of free support. Any support after that period of time will be done in the community 
forums or as paid support. 

Important: 

Before contacting our support team, please check the following sources of information, as you may find the answer you are looking 
for there: 

1. Make sure you are always using the latest version of the plugin 
2. Go over the FAQs inside this manual or check the frequently asked questions section inside Wishlist Member WooCommerce 

Plus plugin's sales page (FAQs tab) on HappyPlugins.com 
3. Go over the documentation of the plugin 
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Open a Support Ticket 

If you haven’t found your answer in any of the above sources, please open a support ticket through our support helpdesk and we 
will get back to you in the next 72 hours. 

Create a new ticket here 
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Got Any Suggestions? 
We are always looking for the next idea… 

Do you have any ideas for new plugins?  

We want to hear from you! 

Please contact us and we might develop it as our next plugin. 

Contact us here  

Thanks!  
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